Patch Notes - v1.0.5.4

Discussion in 'Patch Notes' started by Brainmelter, May 5, 2013.

  1. Brainmelter Team Darkout: Programmer

    Message Count:
    128
    Likes Received:
    68
    • Fixed not being able to craft from containers
    • Fixed unresponsive/missing sled menus
    • Fixed sled menu to close with ESC
    • Fixed sled's go to base function
    • Fixed sled pickup and drop
    • Fixed sled respawn with player
    • Added minimum and maximum distance to sled paths
    • Fixed LightGooJar not emitting light
    • Fixed FireflyJar not emitting light
    • Fixed items discovered in event chests not being recognized
    • Fixed ALT+TAB not always stopping the crafting and research queues
    • Fixed "-1" display in enemy kill messages
    • Fixed plant regrowth density to be much closer to generation. (Change is only partial for old worlds)
    • Fixed some research and crafting items not unlocking properly
    • Fixed endless research points from event chests
    • Fixed world and player lists not displaying properly after changing options
    • Fixed jetpack sound
    • Fixed gravity on throwing flare physics
    • Added new ballistics physics. Currently only being used for the grenade launcher (trajectory helper soon to come!)
    • Changed tar so that it catches on fire and turns into lava when it touches lava
    • Added new data relics
    • Fixed jellyfish death effect
    • Fixed jellyfish attacks hitting player without line of sight
    • Added a scrollbar to the info popup GUI so you can now view past events
    • Fixed potential lost items when inventory is full
    • Changed scrolling through hotbar to allow wraparound
    • Added new menu option to select a different character and world
    • Added new item description display when single clicked
    • Added glow effect to glowing bullets/arrows
    • Changed suit light radius to be set per suit
    • Fixed suit light updating properly with empty battery
    • Fixed platforms blocking player in certain situations
    • Added new ambient occlusion effect between foreground and background tiles
    • Fixed equipment energy usage to update and save properly
    • Added auto save option with customizable delay
    • Added keybind to F5 for manual save
    • Changed laser gun to use anti-matter as well
    • Fixed mining while jumping
    • Optimized game start up to be about 50% faster
    • Added new graphics toggle settings for Bloom, Fluid Effects, Ambient Occlusion, and Shadows
    • Fixed missing font issues
    • Fixed pause to reset properly when starting a new game
    • Fixed equip slots to prevent item stacking
    • Fixed large world seeds crashing the game
    • Added booster timers to booster icons
  2. chronologyte Member

    Message Count:
    65
    Likes Received:
    9
    Awesome work guys!

    Just a reminder to players: Back up your saved characters/worlds from your Documents/My Games/Darkout folder before updating. I had some conversion issues with a couple worlds where all the walls/back-walls got turned to dirt!
    Restoring the backup saves I had made and trying again once or twice got it to convert properly though.

    EDIT:
    Even though it looked fine when I loaded my main world, upon saving and exiting then reloading the same world all my placed back-walls had disappeared! It's better than having all the walls converted to dirt though. I think I will use a sledgehammer to break the back-walls down and save the game again to at least keep from losing them. :)
  3. RavenXavier Member

    Message Count:
    41
    Likes Received:
    8
    Well done indeed :) . Updating now. I should have posted a bug report or looked to see if there was one but in v1.0.5.3J the Glowing Cables didn't glow for me. I only ran 2 space small lines though so maybe I wasn't going it right or maybe their glow hasn't been added yet. I'll see what they do in this update :)

    That's Good Advice. Especially if you've got a world you have tons of work into and really want to keep.

    Honestly though, at least for new players, I'd say don't plan on keeping any worlds made now long term. Better to do screenshots and keep those. I'm sure reintroducing older worlds in newer versions will most likely lead to bigger bugs than just disappearing back walls.

    For my-self I don't plan on really doing a detailed world until I can at least play as a male character . That's just me though. Immersion reasons really.
  4. chronologyte Member

    Message Count:
    65
    Likes Received:
    9
    I didn't think to do it before, but after updating you should do a repair too. It found a few files that needed to be downloaded again and things seem to be a little more stable now. Will report back on more in the bugs forums as well as look into the glowing cables.
    Mine did not glow either but I wonder if that was because they were on the front wall? It's possible that they only glow when used on the back walls so there is actually open space to light up. I'll see what happens. I'm working on a wiring video for the contest and this would be good to know!

    EDIT: Launching the game and just looking at the options menu then exiting will cause the repair to download these files:

    RavenXavier likes this.
  5. RavenXavier Member

    Message Count:
    41
    Likes Received:
    8
    How do you place the cables on the back wall? I thought that's where they went by default. Should I hit shift when placing them to go from front wall to back? Just checking as I'm unsure on what the difference is in placement and how to do it. Much appreciated on any help.
  6. MichaelSeph Darkout Game Tester

    Message Count:
    196
    Likes Received:
    38
    "
    • Fixed missing font issues
    "

    Hi there, sorry, but apparently the numbers 6 and 9 are still not visible, both in the menu (like when picking a resolution) as in-game.
  7. fsovercash Team Darkout

    Message Count:
    55
    Likes Received:
    2
    Two problems I noticed:
    1. Glowtorches don't give off light. (This is really bad.)
    2. There is a weird white effect around the edges of lava caves. I am guessing that it is a missing texture.
  8. chronologyte Member

    Message Count:
    65
    Likes Received:
    9
    The difference is in the placement of the sockets. You can place a socket on the front or back walls, and it will look a little different depending. Then you click and drag (with cables selected) from the middle of the socket and it will start to lay down cables on the way to the next socket. I have not found any devices other than sockets that can be directly connected this way though: the fluorescent and flood lights have to be placed on a back wall but connected with wires strung up rather than laid down with nice cabling. See attached screenshot for examples.
    The glowing cables do indeed seem to glow on the back wall, but they don't act as a light source if the room is dark. That is they are lit but don't light up the surrounding area if that makes sense. The 2nd screenshot shows this. They also light up as such without being connected to a power source.

    [IMG][IMG]

    I stashed all my stuff from my old world and deleted the character, and have been salvaging stuff from my old base using my new character. A few crashes here and there but so far I've been able to cut out some of the grind by grabbing my old stuff.

    If you have the torch not glowing issue and have not tried repairing, do that and it may help according to some other posts I've seen. Otherwise a complete uninstall/reinstall of the game may also do something. For me the repair took care of the biggest issues. Mining seemed to smooth out after a bit even.
  9. RavenXavier Member

    Message Count:
    41
    Likes Received:
    8
    That's incredibly helpful, chronologyte, thank you. Another question if I may. How can I tell if a socket is placed on the back or front wall? I've only placed a few on my last world (deleted now). I placed a generator and a socket. Ran glowing cable from the generator to the socket but it just looked like grey cable so I'm assuming I must have ran it on the front and not the back.
  10. chronologyte Member

    Message Count:
    65
    Likes Received:
    9
    The ones up top that look like a jumbled mess of wires are the front sockets, and the kind of glowy green ones are on the back wall. The red cables are normal and the blue ones are glowing. You can only run cables between sockets on the same layer of wall, but you can connect the back and front by making them adjacent such as the ones to the far right top corner.
    [IMG]

    Maybe we should move this to another thread somewhere lol, so as not to clutter up the patch notes!
  11. RavenXavier Member

    Message Count:
    41
    Likes Received:
    8
    lol true. Much appreciated for clearing that up my friend.
  12. Pysiu Member

    Message Count:
    86
    Likes Received:
    8
    i like the update (much more stable for me) i experience following issues though:
    - torches with no light
    - guns not shooting/shooting with no damage
    - laser gun shooting only at close range (projectile doesn`t show and dmg is dealt only when nearby the enemy)
    - sometimes unable to build
    - constant problem with digging - no issue digging upwards, hard to select anything to dig below (dig "selection boxes" don't appear when attempt to dig downwards)
  13. RavenXavier Member

    Message Count:
    41
    Likes Received:
    8
    Check this thread, might help.

    http://darkoutgame.net/index.php?threads/bug-with-tool-usage-building.1825/page-2#post-8691
    JesusFabre likes this.
  14. chronologyte Member

    Message Count:
    65
    Likes Received:
    9
    There is an update and it seems to have fixed the issues I was having for the most part. Kudos to the devs for getting another patch out so fast!! :D
    JesusFabre likes this.
  15. Pysiu Member

    Message Count:
    86
    Likes Received:
    8
    Checking it out right now! :D
  16. King Doom Member

    Message Count:
    39
    Likes Received:
    6
    On an existing character the patch didn't seem to do anything - I still can't mine and the background tiles still appear to have a 50/50 chance of being visible when I load a world. Tried on an existing world with an existing character and a newly generated world with an existing character.
  17. MichaelSeph Darkout Game Tester

    Message Count:
    196
    Likes Received:
    38
    Well, there is a patch released to fix these, currently 1.0.5.4h ,but the weapons still doesn't shoot any bullet, tried crafting new weapons, work the same. The weapons did work correctly on a new char on a new world though, so I guess it's fine.

    But the "inability" bug also happened on a new world, new char, right at the beggining with the inicial tools. Doing the "Repair fix" now, replacing all, 14k files... it's gonna take a while :)
    JesusFabre likes this.
  18. fsovercash Team Darkout

    Message Count:
    55
    Likes Received:
    2
    As of 1.0.5.4h torches and glowtorches still don't give off light when held, and I still can't mine anything below waist level. I would consider these high priority bugs, since they make the game unplayable for a new character.
  19. King Doom Member

    Message Count:
    39
    Likes Received:
    6
    So.... With the latest patch breaking the ability existing characters have to dig I decided to maybe start a new character. Well, yeah, they CAN dig and as a bonus torches actually create light for them, but unfortunately, they can't place anything. Wooden blocks, dirt blocks and wooden platforms don't work and with the world that I could explore being utterly devoid of anything but dirt I couldn't build anything else.

    Bit of a problem that.
  20. chronologyte Member

    Message Count:
    65
    Likes Received:
    9
    Try deleting those new characters and worlds, and create ANOTHER new char and world. Do this a couple times and see if you are unable to place stuff.
    I did have this bug pop up on a new char and world a couple times, but it was not every time! I made new chars/worlds until I had one that worked and started from there, and was even able to salvage my old world (which had been backed up and wiped clear to try to repair a couple times.)
    I'll see if I can get it to happen again for me with the new patch though.

    EDIT: Did some testing and found something out! I only have the building problem when I load the world after closing another world, without restarting the game. I think it's related to the new feature allowing us to change char/world without exiting the game!

    EDIT2: While this bug is happening, glow torches/flashlight do not glow properly unless the torches are placed, regular torches seem to be working ok for me but I think both the bugs are related to loading a world, then unloading it by returning to main menu, then loading another world.

Share This Page